Website access blocked for older browsers from 27 May

Our hosting provider is changing a configuration to ensure that our websites, and the data hosted on them stay secure. They will block version 1.1 of the TLS protocol, which allows secure website browsing.

You have a choice between the following:

  • Upgrading your browser to the latest version
  • Changing browsers may help, for example starting to use Chrome
  • Updating the configuration in your browser to enable TLS1.2

Instructions to configure your browser are available on the GeoTrust website.

Affected browsers that need an upgrade or alternative browser installed

Desktop

  • IE7 and below
  • Firefox 22 and below
  • Chrome 21 and below
  • Safari 6 and below for OS X 10.8 (Mountain Lion) and below

Mobile

  • Android 4.4 (KitKat) to 4.4.4
  • Chrome 22-37

Affected browsers that can be configured to use TLS1.2

Desktop

  • IE8, IE9, IE10
  • Firefox 23-26
  • Chrome 22-37

Mobile

  • Android 4.4 (KitKat) to 4.4.4
  • Chrome 22-37
Processing...
Thank you! Your subscription has been confirmed. You'll hear from us soon.
ErrorHere